unstick r1870942

Revision 1870942

Date:
2019/12/07 00:16:35
Author:
rwhitcomb
Revision Log:
Update Ant version requirement to 1.10.2 so that we can use the "<javaversion...>"
check to allow Java versions greater or equal to 9 also (builds are failing on
OpenJDK 11 because we didn't have the right version checks).
Files:

Legend:

 
Added
 
Removed
 
Modified
  • pivot/jenkins/build.xml

     
    69 69 <fail>
    70 70 <condition>
    71 71 <not>
    72 <antversion atleast="1.9.0"/>
    72 <antversion atleast="1.10.2"/>
    73 73 </not>
    74 74 </condition>
    75 75 <![CDATA[
    76 76 Error:
    77 77
    78 Building Pivot requires Apache Ant 1.9 or greater. Please see the BUILD
    78 Building Pivot requires Apache Ant 1.10.2 or greater. Please see the BUILD
    79 79 file for more information.
    80 80 ]]>
    81 81 </fail>
     
    86 86 <not>
    87 87 <or>
    88 88 <equals arg1="${ant.java.version}" arg2="1.8"/>
    89 <equals arg1="${ant.java.version}" arg2="1.9"/>
    89 <javaversion atleast="9"/>
    90 90 </or>
    91 91 </not>
    92 92 </condition>